Не удается получить sass + compass + susy из-за конфликта версий

Я работаю с Sass, Compass и Susy на OSX / Terminal. Но я не могу заставить Сюзи работать вместе с Сасс и Компас. Что я наделал:

sudo gem install sass sass -v 

Возвращает: Sass 3.3.0 (Maptastic Maple)

 sudo gem install compass 

Это, похоже, также устанавливает sass-3.2.14.gem, затем compass-0.12.3.gem.

 compass -v 

возвращает: Компас 0.12.3 (Alnilam)

Все, пока эта точка не работает нормально; Я могу создать проект Compass и работать с ним. Затем я пытаюсь установить Susy:

 sudo gem install susy --pre 

или просто

 sudo gem install susy 

Это похоже на установку susy-2.0.0

Чем я бегу:

 compass create /Users/tom/Thomas/htdocs/susi4-test -r susy -u susy 

И я получаю эту ошибку:

 Gem::LoadError on line 2064 of /Library/Ruby/Site/1.8/rubygems/specification.rb: Unable to activate susy-2.0.0, because sass-3.2.14 conflicts with sass (~> 3.3.0) Run with --trace to see the full backtrace 

Таким образом, существует проблема с совместимостью разных версий. Что я могу сделать для устранения этой ошибки?

3 Solutions collect form web for “Не удается получить sass + compass + susy из-за конфликта версий”

Зависимости несовместимы: susy 2.0.0 зависит от sass ~> 3.3.0 тогда как компас 0.12.3 зависит от sass = 3.2.14 .

Сообщение об ошибке говорит то же самое:

Не удалось активировать susy-2.0.0, потому что sass-3.2.14 конфликтует с sass (~> 3.3.0)

Вы можете: a) понизить подозрение до версии, которая работает с sass 3.2.14 или b) обновить компас до версии, совместимой с sass 3.3.x.

Совместимая версия – compass 1.0.0 (или более поздняя) в зависимости от sass < 3.5, >= 3.3.13 . Вы можете установить его через

 gem update compass 

Может быть, проще использовать диспетчер драгоценных камней, например, Bundler . Он автоматически разрешает зависимости и устанавливает соответствующие версии.

 gem install compass --pre 

когда вы устанавливаете последнюю версию компаса, будет иметь ошибку:

 ERROR: While executing gem ... (Gem::UnsatisfiableDependencyError) Unable to resolve dependency: 'compass (= 1.0.0.alpha.19)' requires 'compass-core (~> 1.0.0.alpha.19)' 

Сначала необходимо установить компас-kernel

 gem install compass-core 

Лучший способ, без сомнения, – установить Susy через плагин Compass Susy. Это позволит избежать конфликтов с другими проектами Compass, которые требуют текущей версии.

Команды:

 gem install compass gem install compass-susy-plugin 
Interesting Posts

Как можно скопировать и переименовать файл в Windows?

Какой RAID-контроллер я должен использовать?

Я хочу переименовать один текст для массовых файлов в папку в Windows 7

PSU не проблема, это материнская плата?

Обновите поле MongoDB, используя значение другого поля

SQLite с защитой от шифрования / паролей

Image.Save (..) генерирует исключение GDI +, поскольку stream памяти закрыт

Выбор элементов по атрибуту

Как сделать текстовое поле, которое принимает только числа?

Виртуальный маршрутизатор не работает

Как отображать частоту в верхней части каждого фактора в штриховом шрифте в R

QuickLookSatellite MAC OS, высокая производительность процессора

Почему конечные запятые разрешены в списке?

Угловые 2+ и наблюдаемые: не могут привязываться к ‘ngModel’, поскольку это не известное свойство ‘select’

Можно ли сериализовать и десериализовать class в C ++?

Давайте будем гением компьютера.