Невозможно написать файл кеша jarlist при создании проекта Android

При создании проекта Android в Eclipse я получаю сообщение об ошибке:

[2014-03-13 15:14:36 - appcompat_v7] WARNING: unable to write jarlist cache file C:\Users\Neelakanteshwar\AndroidFirst\appcompat_v7\bin\jarlist.cache

Папка appcompat_v7 создается вместе с папкой проекта в Eclipse.

Может кто-нибудь помочь мне, чтобы получить решение.

Если вы перейдете в appcompat_v7/bin , вы увидите, что файл jarlist.cache не отображается или не jarlist.cache . Вам нужно обновить папку appcompat_v7 , только нажмите F5 над этой папкой.

Папка appcompat_v7 добавляется, потому что вы используете компонент панели действий.

Ааа. Чтобы избежать создания новой папки appcompat_v7_XX при создании нового проекта, выберите API уровня LEVEL как минимальный необходимый SDK.

После этого вы должны модифицировать AndroidManifest.xml и установить необходимый уровень.

  change it android:targetSdkVersion="19" />` 

Берегись! Удалите все appcompat_v7_XX . Это ошибка.

С помощью appcompat_v7 вы увидите, что Eclipse создает два файла XML:

  • activity_main.xml
  • fragment_main.xml

Если вы хотите иметь возможность создавать проект по-старому только с activity_main.xml , выполните следующие действия:

  • Сделайте копию папки «BlanckActivity», расположенной по этому пути: \sdk\tools\templates\activities предыдущей версии ADT.

  • Переименуйте папку как BlankActivityNoFragment , затем отредактируйте имя поля файла template.xml таким образом, чтобы он name=BlankActivityNoFragment

  • Скопируйте новую папку в тот же путь к новой Eclipse IDE: sdk/tools/templates/activities

Теперь вы увидите новый шаблон, когда идете создать новый проект.

Не забудьте выбрать минимально необходимый SDK как API 14

Сегодня такая же проблема.

  • Установите и настройте все необходимые компоненты.

  • В строке меню перейдите в: Project->Properties->Java build path .

  • На вкладке « Заказ» и «Экспорт »: проверьте все библиотеки проектов. Я проверил Android 4.4.

Изменение пути рабочей области при запуске Eclipse:

  • из C:\Users\XXXXXXXX\workspace
  • к, например, D:\My_Folder

Возможно, это не профессиональный подход, но это сработало для меня.

  • Вручную создайте папку с именем jar в пути: C:\Users\\***\appcompat_v7\bin\
  • Реферируйте свой проект в затмении.

Это потому, что вам также нужна версия Adroid 2.1! Зайдите в Android SDK Manager и загрузите версию Android 2.1 (API 7)

Если вы запустите новое приложение для Android. В проекте написано, что от версии 2.1 до 4.4 версии Android. Значит, программа ищет минимальную версию Android для Android 🙂

BTW: Загрузите 2.2. Версия Android тоже. 🙂

Сегодня у меня такая же проблема.

В моем случае сочетание ваших советов стало решением:

  1. В панели проектов Eclipse я удалил Appcompat (XYZ) и новый проект, который я только что создал.

  2. Проверено на наличие обновлений – обновлений не обнаружено.

  3. Щелкните Файл -> Перезагрузка.

  4. При создании нового проекта выбрали API 14 как минимальный необходимый SDK.

Готово.

Запустите обновление Eclipse (Справка -> Проверить наличие обновлений) и сообщите мне, разрешает ли это ваши проблемы.

Просто обновите папку bin appcompat_v7!

Это сработало для меня. При создании поддержки android-support-v7-appcompat отметьте опцию «Копировать проекты в рабочее пространство». Теперь он может записываться в нужные каталоги. Надеюсь, это поможет вам.

Ну … Я встретил такую ​​же ситуацию. Я удалил свой проект из затмения и на диске, удалил рабочую область с диска и воссоздал проект в новом рабочем пространстве … он работает …….

В моем случае работал другой подход, говоря об этом, если он может помочь кому-то. Я также столкнулся с этой странной проблемой appcompat при создании нового проекта.

Я просто appcompat_v7 проект appcompat_v7 по умолчанию в течение 2 раз, который создается самим eclipse, и он работает! и все ошибки ушли, отлично работает.

Я получил ту же ошибку, и для меня были выполнены следующие шаги.

Просто удалите папки gen и bin

Очистите (перестройте) проект.

 Вот простой трюк: * 
Создать новый проект
Если вы получите предупреждение о jarlist Не создано на вкладке консоли
Закройте Eclipse и снова откройте его.
Теперь ур сделал. jarlist включен в appcompat_7 / bin или appcompat_7_XX / bin
Давайте будем гением компьютера.