Не найден ресурс, который соответствует указанному имени (в диалогеCornerRadius со значением «? Android: attr / dialogCornerRadius»)

Может кто-нибудь помочь, почему это дает ошибку?

Все работало нормально, и внезапно эта ошибка появляется.

Я googled, но ничего не мог получить! Пожалуйста помоги

Ошибка: (7, 41) Ресурс не найден, который соответствует указанному имени (в диалоговом окне «dialogCornerRadius» со значением «? Android: attr / dialogCornerRadius»).

apply plugin: 'com.android.application' //Add these lines def Base_URL = '"' + WEBServiceBaseURL + '"' ?: '"Define BASE URL"'; def SMS_Base_URL = '"' + WEBServiceBaseSMSURL + '"' ?: '"Define SMS BASE URL"'; android.buildTypes.each { type -> type.buildConfigField 'String', 'Base_URL', WEBServiceBaseURL type.buildConfigField 'String', 'SMS_Base_URL', WEBServiceBaseSMSURL } android { compileSdkVersion 26 buildToolsVersion "26.0.1" defaultConfig { applicationId "com.bla.bla" minSdkVersion 19 targetSdkVersion 26 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" multiDexEnabled true } buildTypes { release { minifyEnabled true shrinkResources true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile 'com.android.support:appcompat-v7:26.+' compile 'com.android.support.constraint:constraint-layout:1.0.2' testCompile 'junit:junit:4.12' compile 'com.android.support:design:+' compile files('libs/jxl-2.6.jar') compile 'com.google.gms:google-services:+' compile 'com.google.firebase:firebase-core:11.8.0' compile 'com.google.firebase:firebase-messaging:11.8.0' } apply plugin: 'com.google.gms.google-services' 

Я исправил эту проблему, выбрав

API 27+: Android API 27, P preview (Предварительный просмотр)

в структуре проекта. Это мои настройки и 13 ошибок, которые я скрыл.

введите описание изображения здесь

Измените compile 'com.android.support:design:+' строки compile 'com.android.support:design:+' для compile 'com.android.support:design:26.+'

Зависимости gradleиентов при построении проекта сводятся к последним версиям, так как « + сообщал «получить последнюю версию». 26.+ сообщит процессу сборки только обновление последней версии v26.

Или, чтобы быть более конкретным и безопасным, измените линию на определенную версию, избегая + вообще. т.е. compile 'com.android.support:design:27.1.0'

После помощи Everybody я смог решить эту проблему и запустить приложение в более низкой версии.

Мой обновленный build.gradle выглядит следующим образом.

Особая благодарность всем гениальным людям!

 apply plugin: 'com.android.application' android.buildTypes.each { type -> type.buildConfigField 'String', 'Base_URL', WEBServiceBaseURL type.buildConfigField 'String', 'SMS_Base_URL', WEBServiceBaseSMSURL } android { compileSdkVersion 27 buildToolsVersion "26.0.2" defaultConfig { applicationId "com.dummy.dummy" minSdkVersion 15 targetSdkVersion 22 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" multiDexEnabled true } buildTypes { release { minifyEnabled true shrinkResources true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile 'com.android.support:appcompat-v7:26.+' compile 'com.android.support.constraint:constraint-layout:1.0.2' testCompile 'junit:junit:4.12' compile 'com.android.support:design:26.+' compile files('libs/jxl-2.6.jar') compile 'com.google.gms:google-services:+' compile 'com.google.firebase:firebase-core:11.8.0' compile 'com.google.firebase:firebase-messaging:11.8.0' } apply plugin: 'com.google.gms.google-services' 

забыть о динамических зависимостях и заменить их на определенные конкретные версии:

НЕПРАВИЛЬНО :

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile 'com.android.support:appcompat-v7:26.+' compile 'com.android.support.constraint:constraint-layout:1.0.2' testCompile 'junit:junit:4.12' compile 'com.android.support:design:+' compile files('libs/jxl-2.6.jar') compile 'com.google.gms:google-services:+' compile 'com.google.firebase:firebase-core:11.8.0' compile 'com.google.firebase:firebase-messaging:11.8.0' } 

ВЕРНЫЙ :

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile 'com.android.support:appcompat-v7:26.1.0' compile 'com.android.support.constraint:constraint-layout:1.0.2' testCompile 'junit:junit:4.12' compile 'com.android.support:design:26.1.0' compile files('libs/jxl-2.6.jar') compile 'com.google.gms:google-services:3.1.1' compile 'com.google.firebase:firebase-core:11.8.0' compile 'com.google.firebase:firebase-messaging:11.8.0' } 

Измените следующие параметры в gradleиенте:


 compile 'com.android.support:design:+' 

чтобы:

 compile 'com.android.support:design:26.1.0' 

 'com.android.support:appcompat-v7:26.+' 

чтобы:

 'com.android.support:appcompat-v7:26.1.0' 

Обратите внимание, что вы можете указать любую версию, но убедитесь, что обе они имеют одну и ту же версию.

Это гарантирует, что файл values-28.xml не будет создан.

установите compileSdkVersion 28, чтобы загрузить файлы платформы для Android.

  • Как я могу обработать перенос карты с помощью Google Maps для Android V2?
  • Что такое предупреждающий вывод «Игнорирование InnerClasses» во время компиляции?
  • В чем разница между compileSdkVersion и targetSdkVersion?
  • Режим Wakelock и doze
  • Выполнить AsyncTask несколько раз
  • Как остановить воспроизведение видео на YouTube в Android-браузере?
  • Как перенести некоторые данные в другой fragment?
  • Открыть страницу Facebook в приложении Facebook (если установлена) на Android
  • Как изменить имя приложения Android?
  • Элементы ListView не доступны для кликов. Зачем?
  • Изображение на canvasе в файл JPEG
  • Interesting Posts

    .c vs .cc против .cpp vs .hpp vs .h vs .cxx

    VBA ServerXMLHTTP запрос https с самозаверяющим сертификатом

    Как использовать JSON.NET для десериализации в вложенный / рекурсивный словарь и список?

    Цифровой знак электронной почты Gmail с S / MIME

    Как загрузить баланс 2 подключения к Интернету на компьютере под управлением Windows 7?

    Как использовать переменные в одиночных кавычках?

    Ложноположительная ошибка «неопределенной переменной» при компиляции SCSS

    Реализация по умолчанию для Object.GetHashCode ()

    Доступ к интерфейсу пользовательского интерфейса (Main) безопасно в WPF

    Regex lookahead для ‘не сопровождается’ в grep

    Как изменить каталог монтирования образа диска по умолчанию на osx

    Удаленный доступ к SSH не работает, когда клиент OpenVPN включен в DD-WRT

    Убедитесь, что приложение находится на первом запуске

    Как изменить fontFamily TextView в Android

    Как изменить цвет фона окна по умолчанию в Windows 10?

    Давайте будем гением компьютера.