Не удалось вставить новое выходное соединение

Не удалось вставить новое выходное соединение: не удалось найти какую-либо информацию для classа и не показывать class с именем «ViewController»

Решения, которые я сделал: – Перезапуск XCode – Перезапуск системы – Удалено содержимое Deriveddata из / Library / developer / xcode

Но для меня ничего не работало

Вот скриншот для ошибки введите описание изображения здесь

    У меня такая же проблема, как и вы сегодня … Я думаю, что это ошибка Xcode, ниже – способ исправить проблему:

    1. Закройте проект, над которым вы работаете.
    2. Удалите папку «DerivedData» вашего проекта. (Эта папка может находиться внутри папки вашего проекта или внутри ~ / Library / Developer / Xcode / DerivedData / (ваш проект) /) или в другом месте, которое было настроено вами.
    3. перезапустите свой проект.

    После этих шагов проблема должна быть решена. И, по моему опыту, эти шаги могут решить многие проблемы с Xcode, поэтому, если у вас возникла некоторая проблема с Xcode, сначала выполните эти шаги.

    Удаление (удаление ссылки, а не удаление), а затем добавление соответствующего файла (файла classа, который вы хотите добавить к нему), на самом деле достаточно.

    Изменить 1 Я обнаружил, что после снятия отметки (в XCode 6.3.1) мне пришлось подождать несколько секунд, чтобы Indexing появилось и завершилось в поле имени проекта. То же самое для обратного пути. Это увеличило шансы исправить проблему почти во всех (но не во всех) случаях.

    Редактирование 2 Удаление ссылки означает, что вы не удаляете файл полностью, а просто удаляете его из проекта (он все еще существует в папке вашего проекта, вы добавляете его позже).

    введите описание изображения здесь

    Это чаще всего проблема file indexing .

    Чтобы исправить это, попробуйте clean your target и если это не сработает, перейдите в свою папку Derived Data и удалите там свое приложение. Это заставит xCode повторно проиндексировать файлы

    Просто получил ту же проблему на Xcode 4.6.2.
    Пробовал решения, представленные в разных ответах / комментариях, но он все еще не работал.

    Тогда все, что я сделал, было просто:

    1. сохранить всю мою работу;
    2. просто закройте Xcode и загрузите его снова;
    3. то я смог успешно установить новое выходное соединение.

    Надеюсь, это сэкономит время / разочарование для кого-то другого.

    Лично у меня была такая же проблема: «не удалось вставить новое выходное соединение» И когда я начал набирать что-то вроде «UI …», XCode ничего не делал. Я искал ответы, я пробовал несколько вещей … но это была просто непроверенная коробка. Когда я создавал новый class, XCode снял флажок, связывающий class с проектом (я думаю).

    Я не могу опубликовать снимок экрана, потому что у меня нет 10 репутаций, но когда вы создаете свой class, XCode спрашивает вас, где вы хотите его сохранить. В окне поиска у вас есть «Цели» и два поля: «YouProjectName» и «YouProjectNameTests». Вы должны проверить первый (по крайней мере).

    Надеюсь, это поможет. Я видел разные дискуссии по этому вопросу.

    скриншот при создании нового класса

    Я недавно столкнулся с этой проблемой. Вскоре я понял, что дело было моим делом. Раньше я отключил индексирование XCode (которое использовалось для того, чтобы взять навсегда и съесть мою оперативную память), используя приведенный ниже код в окне терминала:

     defaults write com.apple.dt.XCode IDEIndexDisable 1 

    Чтобы вернуть XCode в состояние по умолчанию, я использовал следующую строку в окне терминала:

     defaults write com.apple.dt.XCode IDEIndexDisable 0 

    Вуаля! Все хорошо снова ..

    Если вы импортировали class в свой проект Xcode, вы должны вручную добавить файл classа (.m) в свои «Источники компиляции».

    Выберите значок проекта> ЦЕЛИ> Фазы сборки> Скомпилировать источники Нажмите кнопку + и добавьте файл * .m.

    Наконец, я сделал это, полностью удалив xcode с моего mac и переустановил файл xocde.dmg, а затем установил MobileDevice.pkg и MobileDeviceDevelopment.pkg, находящиеся в /Applications/Xcode.app/Contents/Resources/Packages

    убедитесь, что ваш источник был включен в место «Фазы сборки».

    Это исправляет мою проблему. Но я думаю, что Xcode по-прежнему действительно глючит и раздражает.

    Давайте будем гением компьютера.