Не удалось решить: com.google.firebase: firebase-core: 11.2.0

При синхронизации моего проекта я получаю несколько проблем «Не удалось разрешить». Все они связаны с огнем и игровыми сервисами. Я убедился, что они все одинаковые (11.2.0). Я также проверил, и последняя версия для обоих – 11.2.0. Кроме того, все остальные ответы на подобные вопросы include обновление сервисов Google и репозитория в SDK Manager, но мой уже обновлен.

введите описание изображения здесь

введите описание изображения здесь

Любая идея, почему я не могу синхронизировать свой проект?

EDIT – текущее рабочее решение

// Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.3.3' classpath 'com.google.gms:google-services:3.0.0' classpath 'com.google.firebase:firebase-plugins:1.0.4' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } task clean(type: Delete) { delete rootProject.buildDir } 

    Добавьте maven { url "https://maven.google.com" } в свой файл build.gradle уровне build.gradle

     allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

    Игровые сервисы и зависимости Firebase теперь доступны через maven.google.com с выпуском версии 11.2.0 сервисов Google Play и Firebase.

    Здесь вы можете найти официальный документ Google Play Services и документ firebase. ,

     allprojects { repositories { jcenter() maven { url 'https://maven.google.com' } } } 

    Если вы используете плагин android gradle 3.x, вы также можете использовать:

     allprojects { repositories { jcenter() google() } } 

    Лучший способ исправить эту проблему – это не использование ручного метода связывания firebase с вашим приложением.

    Я попытался добавить последнее repository firebase, обратившись к этой ссылке .

    Он показал ошибку «не удалось разрешить firebase 11.2.0 зависимостей»,

    FireBase рекомендует добавлять firebase в ваше приложение с помощью FireBase Assistant для Android Studio версии 2.2 и выше. Вручную добавление последней библиотеки в build-gradle (module) приводит к ошибке, как указано выше.

    Помощник Firebase добавил более низкие версии 10.0.1 автоматически в зависимости от модуля gradle-build, который совместим и может быть разрешен.

    Использование помощника Firebase – это простой и двухэтапный процесс. Для справки, вы можете использовать раздел «Использовать помощник Firebase» по той же ссылке, о которой говорилось выше.

    Это действительно сработало с моей Android Studio 2.3.3. Кроме того, убедитесь, что ваш repository Google обновлен

    Я просто исправил ту же ошибку, добавив зависимость от базового ядра .

     implementation 'com.google.firebase:firebase-core:16.0.1' 

    С выпуском 16.0.0 мне пришлось

    • установить большинство моих библиотек игровых сервисов google для аналитики 15.0.0 а tagmanager должен быть 16.0.0
    • установите версии моей поддерживающей библиотеки на 27.1.1
    • firebase-core до 16.0.0

    Построено против sdk 27

    Дополнительные изменения:

    Мне также пришлось обновить мою аналитику до 16.0.0

    • реализация “com.google.android.gms: play-services-analytics: 16.0.0”

    Часть независимых версий, которые Android недавно сделал, я угадываю. Возможно, потребуется попробовать перейти вверх или вниз по версии в сервисах google play и библиотеках firebase

    Давайте будем гением компьютера.