Не удается установить Java 1.6 на OS X 10.5.8

Официальные обновления Apple позволяют мне получить только java version "1.5.0_30" . Я пытаюсь применить обновление 1.6 вручную с помощью JavaForMacOSX10.5Update6.pkg и это дает мне

Более новая версия этого пакета уже установлена.

Я пробовал это:

 cd /System/Library/Frameworks/JavaVM.framework/Versions sudo rm -fr CurrentJDK sudo ln -s 1.6 CurrentJDK 

И ничего хорошего … Как я могу получить 1.6?

Я даже посмотрел на этот вопрос, установленный Update 10, и теперь у меня есть 1.6 и 1.6.0 в /System/Library/Frameworks/JavaVM.framework/Versions и current папка также имеет файлы 1.6, но в настройках java у меня есть только 1.4.2 и J2SE 5.0 (1.5)

Java-предпочтения

UPDATE : Кажется, 32-битная OSX поддерживает только до 1.5, и у них нет официального способа запуска 1.6 на не 64-битном …
Есть ли способ вокруг него? Я пытаюсь запустить PHPstorm, для которого требуется 1.6

Давайте будем гением компьютера.