Tag: r

Совокупность / суммирование нескольких переменных для каждой группы (например, сумма, среднее значение)

Из фрейма данных существует ли простой способ одновременного агрегирования ( sum , mean , max et c) нескольких переменных? Ниже приведены некоторые примеры данных: library(lubridate) days = 365*2 date = seq(as.Date(“2000-01-01”), length = days, by = “day”) year = year(date) month = month(date) x1 = cumsum(rnorm(days, 0.05)) x2 = cumsum(rnorm(days, 0.05)) df1 = data.frame(date, year, […]

Стэнфордский Wrangler идеален, но налагает ограничения, какие другие варианты?

Инструмент Stanford Wrangle довольно изумительный, и я решил гигантскую проблему с ним, но он ограничивает меня очень маленькими размерами. Мой файл составляет около 500 МБ, и он позволяет обрабатывать менее 1 МБ, остальные данные просто свернуты в одну ячейку. После 15-й строки (в нескольких файлах) она просто останавливается http://vis.stanford.edu/wrangler/app/ У меня есть 50 тыс. Следующих […]

Как обновить R на Cent OS?

У меня проблемы с обновлением R на CentOS. Я запустил «yum remove R» и вернул успешное сообщение. Но когда я набираю R, он все еще загружает среду R. Нужно ли сначала удалить его другим способом перед обновлением? Я запускаю R версии 2.15.2

Каков наилучший способ слияния двух наборов файлов, но для дубликатов для выбора старого файла в Windows?

Я наткнулся на немой случай использования. Я хочу объединить две папки определенным образом (я думаю, теперь они называются папками, я все еще думаю о них как о каталогах, но что бы там ни было). Папки имеют следующие характеристики: Во многом одинаковый контент (но в каждом уникальном содержимом) Во многом идентичная структура папок Папка A имеет […]

Установка R в RHEL 7

Я применил следующие шаги для установки R в RHEL 7: yum install epel-release yum update yum install R Но у меня появились ошибки: –> Finished Dependency Resolution Error: Package: R-core-devel-3.3.1-2.el7.x86_64 (epel) Requires: gcc-c++ Error: Package: R-core-3.3.1-2.el7.x86_64 (epel) Requires: tex(dvips) Error: Package: R-core-devel-3.3.1-2.el7.x86_64 (epel) Requires: tex(latex) Я попробовал несколько предложений, размещенных в Интернете, но ничего не […]

Давайте будем гением компьютера.